Ticket #5 (closed defect)

Opened 12 years ago

Last modified 11 years ago

'make install' does nothing

Reported by: nonhuman Owned by:
Priority: normal Milestone:
Component: Version:
Keywords: Cc: nonhuman, sarag
Blocked By: Blocks:


If I run the command './configure && make all install' on a machine
Mac OS X 10.4.2 (Darwin 8.2.0) it doesn't actually install the
library. As far as I can tell the ./configure works fine, and make all
compiles things fine, but make install does nothing. One strange
thing I noticed as that the final product of this process seems to
be a file called ssh2_sample.o rather than libssh2.o or something
like that. Here's the output I get when I run the above command:

gcc -o channel.o channel.c -c -DLIBSSH2_DARWIN -I/usr/include
-I/usr/include -Wall -g -I../include/ -fPIC
gcc -o comp.o comp.c -c -DLIBSSH2_DARWIN -I/usr/include -I/
usr/include -Wall -g -I../include/ -fPIC
gcc -o crypt.o crypt.c -c -DLIBSSH2_DARWIN -I/usr/include -I/
usr/include -Wall -g -I../include/ -fPIC
gcc -o hostkey.o hostkey.c -c -DLIBSSH2_DARWIN -I/usr/
include -I/usr/include -Wall -g -I../include/ -fPIC
gcc -o kex.o kex.c -c -DLIBSSH2_DARWIN -I/usr/include -I/usr/
include -Wall -g -I../include/ -fPIC
gcc -o mac.o mac.c -c -DLIBSSH2_DARWIN -I/usr/include -I/usr/
include -Wall -g -I../include/ -fPIC
gcc -o misc.o misc.c -c -DLIBSSH2_DARWIN -I/usr/include -I/
usr/include -Wall -g -I../include/ -fPIC
gcc -o packet.o packet.c -c -DLIBSSH2_DARWIN -I/usr/include -
I/usr/include -Wall -g -I../include/ -fPIC
gcc -o scp.o scp.c -c -DLIBSSH2_DARWIN -I/usr/include -I/usr/
include -Wall -g -I../include/ -fPIC
gcc -o session.o session.c -c -DLIBSSH2_DARWIN -I/usr/include
-I/usr/include -Wall -g -I../include/ -fPIC
gcc -o sftp.o sftp.c -c -DLIBSSH2_DARWIN -I/usr/include -I/usr/
include -Wall -g -I../include/ -fPIC
gcc -o userauth.o userauth.c -c -DLIBSSH2_DARWIN -I/usr/
include -I/usr/include -Wall -g -I../include/ -fPIC
gcc -o libssh2.dylib channel.o comp.o crypt.o hostkey.o kex.o
mac.o misc.o packet.o scp.o session.o sftp.o userauth.o -L/usr/
lib -lcrypto -L/usr/lib -lz -dynamiclib -flat_namespace -lm
gcc -o ssh2_sample.o ssh2_sample.c -c -DLIBSSH2_DARWIN -I/
usr/include -I/usr/include -Iinclude/ -Wall -g
gcc -o ssh2_sample ssh2_sample.o -lssh2 -Lsrc/
make: `install' is up to date.


a.txt (1 bytes) - added by cleans 3 years ago.
domestic cleaning services

Download all attachments as: .zip

Change History

comment:1 Changed 11 years ago by sarag

Sorry to only just get back to you. The library was built
in that output, it's "src/libssh2.dylib". Now, as to why
nothing was installed... I'm not so sure...

I'm not seeing some of the usual make output in what you
pasted... Perhaps that's just a difference between GNU make
and what MacOSX uses.

I'll see if I can get my hands on a MacOSX box to do some

comment:2 Changed 11 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Changed 3 years ago by cleans

Note: See TracTickets for help on using tickets.