Ticket #78 (closed defect)

Opened 9 years ago

Last modified 8 years ago

libssh2 core dumps under AIX 5.3

Reported by: jheiden2 Owned by:
Priority: normal Milestone:
Component: Version:
Keywords: Cc: jheiden2, dfandrich, bagder
Blocked By: Blocks:

Description

Hi,

Recently I found I need to transfer some files to
remote sites. After researching, it seems that
cURL and libssh2 are the only way I can go with
this.

So I built libssh2 and cURL as documented and things
seemed to go well until I tried used cURL to SFTP
a file to another server. It core dumps. Then I
went back to libssh2 and did a make check, but that
was smooth. So I tried the sftp and scp programs
that come with libssh2, and both of those core
dump as well.

Let's see, this is under AIX 5.3.0.0, and I built it
with GCC 4.2.4.

Does anyone know of a fix or work around for this issue?
If so, can somebody get back to me?

Your help would be greatly appreciated.

Sincerely

John Heiden
Unix Systems Admin.
The University of Toledo
Toledo, OH 43606
John.Heiden@…
419.530.3976

Change History

comment:1 Changed 9 years ago by dfandrich

What procedure did you use to compile? You'll have to narrow the problem further in order to get some help. Try running the test program under a debugger and find out exactly where the core dump occurs and what's causing it. You may need to enable debug support when compiling libssh2 in order to get the most benefit from the debugger. Also, try enabling libssh2 logging to help narrow it further.

comment:2 Changed 9 years ago by jheiden2

I followed the doc and did a ./configure, then a make, then a make check, and finally a make install.

Can you point me at some docs for doing what you suggest? I don't mind doing what you ask, but I am
not familiar with the debuggers.

comment:3 Changed 9 years ago by dfandrich

I'm not familiar with AIX so I can't give you specific instructions. Some common debugger names are gdb, db, and dbx. All you should need to figure out is how to run your program from the debugger then get a backtrace when it segfaults.

comment:4 Changed 8 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.